aboutsummaryrefslogtreecommitdiff
path: root/paludis/repositories/e/e_repository_TEST_5.cc
diff options
context:
space:
mode:
authorAvatar David Leverton <levertond@googlemail.com> 2015-11-08 20:06:17 +0000
committerAvatar David Leverton <levertond@googlemail.com> 2015-11-08 20:06:17 +0000
commit3a15cc2c588145d179d6cf48ba412b798e580a3e (patch)
tree5aced4ccf51dbbb57b33753a4cf0fb599801cb87 /paludis/repositories/e/e_repository_TEST_5.cc
parent5b89f3bd40d17d06e3a1f26471461a3ae544c676 (diff)
downloadpaludis-3a15cc2c588145d179d6cf48ba412b798e580a3e.tar.gz
paludis-3a15cc2c588145d179d6cf48ba412b798e580a3e.tar.xz
Set appropriate compat* shopt
EAPI 6 specifies bash 4.2 instead of 3.2. The spec now recommends setting the compatibility level for both old and new EAPIs.
Diffstat (limited to 'paludis/repositories/e/e_repository_TEST_5.cc')
-rw-r--r--paludis/repositories/e/e_repository_TEST_5.cc9
1 files changed, 9 insertions, 0 deletions
diff --git a/paludis/repositories/e/e_repository_TEST_5.cc b/paludis/repositories/e/e_repository_TEST_5.cc
index c482655b8..57611e02f 100644
--- a/paludis/repositories/e/e_repository_TEST_5.cc
+++ b/paludis/repositories/e/e_repository_TEST_5.cc
@@ -366,6 +366,15 @@ TEST(ERepository, InstallEAPI5)
EXPECT_EQ("5", visitor_cast<const MetadataValueKey<std::string> >(**id->find_metadata("EAPI"))->parse_value());
id->perform_action(action);
}
+
+ {
+ const std::shared_ptr<const PackageID> id(*env[selection::RequireExactlyOne(generator::Matches(
+ PackageDepSpec(parse_user_package_dep_spec("=cat/bash-compat-5",
+ &env, { })), nullptr, { }))]->last());
+ ASSERT_TRUE(bool(id));
+ EXPECT_EQ("5", visitor_cast<const MetadataValueKey<std::string> >(**id->find_metadata("EAPI"))->parse_value());
+ id->perform_action(action);
+ }
}
TEST(ERepository, RequiredUse)