summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvatar Heiko Becker <heirecka@exherbo.org> 2017-09-13 21:57:46 +0200
committerAvatar Heiko Becker <heirecka@exherbo.org> 2017-09-14 15:25:59 +0200
commita8130ff3e6fb88ba5967bff5f7c93ff8ef10a74d (patch)
tree860cfe370887160393a991ea111173fed41db8d0
parentebacb8de5585684d1faf7883c01766c422fbd3dc (diff)
downloadkde-a8130ff3e6fb88ba5967bff5f7c93ff8ef10a74d.tar.gz
kde-a8130ff3e6fb88ba5967bff5f7c93ff8ef10a74d.tar.xz
plasma-sdk: Version bump to 5.10.95
-rw-r--r--metadata/repository_mask.conf1
-rw-r--r--packages/kde/plasma-sdk/plasma-sdk-5.10.95.exheres-017
-rw-r--r--packages/kde/plasma-sdk/plasma-sdk.exlib14
3 files changed, 29 insertions, 3 deletions
diff --git a/metadata/repository_mask.conf b/metadata/repository_mask.conf
index 814b6b5..4a984d8 100644
--- a/metadata/repository_mask.conf
+++ b/metadata/repository_mask.conf
@@ -575,6 +575,7 @@ net-irc/kvirc [[
kde/oxygen[~>5.10.95]
kde/plasma-desktop[~>5.10.95]
kde/plasma-integration[~>5.10.95]
+ kde/plasma-sdk[~>5.10.95]
kde/plasma-workspace[~>5.10.95]
kde/powerdevil[~>5.10.95]
kde/systemsettings[~>5.10.95]
diff --git a/packages/kde/plasma-sdk/plasma-sdk-5.10.95.exheres-0 b/packages/kde/plasma-sdk/plasma-sdk-5.10.95.exheres-0
new file mode 100644
index 0000000..fcb13d1
--- /dev/null
+++ b/packages/kde/plasma-sdk/plasma-sdk-5.10.95.exheres-0
@@ -0,0 +1,17 @@
+# Copyright 2015 Heiko Becker <heirecka@exherbo.org>
+# Distributed under the terms of the GNU General Public License v2
+
+require plasma-sdk
+
+PLATFORMS="~amd64"
+
+MYOPTIONS="
+ ( linguas:
+ ar ast be be@latin bg bn_IN bs ca ca@valencia cs csb da de el en_GB eo
+ es et eu fa fi fr fy ga gl gu he hi hne hr hsb hu ia id is it ja kk km
+ kn ko ku lt lv mai mk ml mr ms nb nds ne nl nn oc or pa pl pt pt_BR ro
+ ru se si sk sl sq sr sr@ijekavian sr@ijekavianlatin sr@latin sv ta te
+ tg th tr ug uk wa zh_CN zh_TW
+ )
+"
+
diff --git a/packages/kde/plasma-sdk/plasma-sdk.exlib b/packages/kde/plasma-sdk/plasma-sdk.exlib
index 2e522b2..6b85c45 100644
--- a/packages/kde/plasma-sdk/plasma-sdk.exlib
+++ b/packages/kde/plasma-sdk/plasma-sdk.exlib
@@ -33,13 +33,10 @@ DEPENDENCIES="
kde-frameworks/ki18n:5[>=${KF5_MIN_VER}]
kde-frameworks/kio:5[>=${KF5_MIN_VER}]
kde-frameworks/kiconthemes:5[>=${KF5_MIN_VER}]
- kde-frameworks/kitemmodels:5[>=${KF5_MIN_VER}]
kde-frameworks/kpackage:5[>=${KF5_MIN_VER}]
kde-frameworks/kservice:5[>=${KF5_MIN_VER}]
kde-frameworks/ktexteditor:5[>=${KF5_MIN_VER}]
kde-frameworks/kwidgetsaddons:5[>=${KF5_MIN_VER}]
- kde-frameworks/kwindowsystem:5[>=${KF5_MIN_VER}]
- kde-frameworks/kxmlgui:5[>=${KF5_MIN_VER}]
kde-frameworks/plasma-framework:5[>=${KF5_MIN_VER}]
x11-libs/qtbase:5[>=5.4.0]
x11-libs/qtdeclarative:5[>=5.4.0]
@@ -50,6 +47,17 @@ DEPENDENCIES="
x11-libs/qtquickcontrols:5[>=5.4.0]
"
+if ever at_least 5.10.95 ; then
+ :
+else
+ DEPENDENCIES+="
+ build+run:
+ kde-frameworks/kitemmodels:5[>=${KF5_MIN_VER}]
+ kde-frameworks/kwindowsystem:5[>=${KF5_MIN_VER}]
+ kde-frameworks/kxmlgui:5[>=${KF5_MIN_VER}]
+ "
+fi
+
DEFAULT_SRC_PREPARE_PATCHES+=(
"${FILES}"/${PN}-Disable-test-which-needs-X.patch
)