summaryrefslogtreecommitdiff
path: root/packages/dev-lang/node
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dev-lang/node')
-rw-r--r--packages/dev-lang/node/node-15.0.0.exheres-0 (renamed from packages/dev-lang/node/node-14.11.0.exheres-0)0
-rw-r--r--packages/dev-lang/node/node.exlib9
2 files changed, 9 insertions, 0 deletions
diff --git a/packages/dev-lang/node/node-14.11.0.exheres-0 b/packages/dev-lang/node/node-15.0.0.exheres-0
index d49cecf71..d49cecf71 100644
--- a/packages/dev-lang/node/node-14.11.0.exheres-0
+++ b/packages/dev-lang/node/node-15.0.0.exheres-0
diff --git a/packages/dev-lang/node/node.exlib b/packages/dev-lang/node/node.exlib
index 24db75d7f..8ee4d37e7 100644
--- a/packages/dev-lang/node/node.exlib
+++ b/packages/dev-lang/node/node.exlib
@@ -34,6 +34,7 @@ RESTRICT="test"
# See TODO above
# providers:libressl? ( dev-libs/libressl )
# providers:openssl? ( dev-libs/openssl )
+# TODO: shared ngtcp2 & nghttp3 for >= 15.0.0
DEPENDENCIES="
build+run:
app-arch/brotli[>=1.0.9]
@@ -45,6 +46,14 @@ DEPENDENCIES="
!bundled-openssl? ( dev-libs/openssl[>=1.1.1g] )
"
+if ever at_least 15.0.0; then
+ DEPENDENCIES+="
+ build+run:
+ dev-libs/libuv[>=1.40.0]
+ net-dns/c-ares[>=1.16.1-r1]
+ "
+fi
+
if ever at_least 14.0.0; then
DEPENDENCIES+="
build: